Guest User

While using the jre 1.7 version, I applied the following option to run the tomcat. But noticed an error like below.
export JAVA_OPTS=“$JAVA_OPTS \
-javaagent:/opt/jennifer/agent4.6/lwst.javaagent.jar -Djennifer.config=/opt/jennifer/agent4.6/QE1.conf”

Exception in thread “main” java.lang.ClassNotFoundException: com.javaservice.lwst.jdk15.JenniferHook
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
at sun.instrument.InstrumentationImpl.loadClassAndStartAgent(InstrumentationImpl.java:300)
at sun.instrument.InstrumentationImpl.loadClassAndCallPremain(InstrumentationImpl.java:397)
FATAL ERROR in native method: processing of -javaagent failed
Please tell me what to do. Thanks.

Khalid Saeed

If you would like to apply only –javaagent and jennifer.config, you need to apply the jennifer.javaagent.jar.