Guest User

hi. I noticed a message of “TcpSocketServer : maximum “number_of_tcp_pooled_workers = 300” reached.” even after the old area of heap memory became FullGC, i could not do monitoring. (sometimes the server went down due to out of memory.) if the option value of number_of_tcp_pooled_workers was changed from 80 to 300, the error still exists, should i reset the value to more than 300 or maybe other reasons caused the problem while the actual number of Client TCP Worker is enough? please let me know what needs to be considered for resetting the option. if there are other reasons, how could i track down the root causes?

Khalid Saeed

the message you received is not the direct cause. if gc is not working, there are too many different application names or query. if you check the rv, sv time at the JENNIFER server log, you would notice that the sv time became too long. if this caused the problme, you need to make the application name.