Guest User

When starting the Tomcat(6.0.26) server, everything looks on the log. But when calling an URL, I get the
“Servlet default is not available” error message.
I followed the instructions in the installation manual and everything was ok. But I can’t start the agent in the server and also the server goes down.
JENINIFER server port 8096 was used instead of 7900. And server_tcp_port was set to 8095 instead of 6701.
server : ia64 hp server rx2660
os : hp-ux b.11.31
was : tomcat 6.0.26

Khalid Saeed

By any chance, are the JENNIFER server and agent installed in the same server?

Your JENNIFER server operated in tomcat5.5.
By any change, did you set CATALINA_HOMEin the environment variable?
If so, delete the environment variable and set it in the catalina.bat file of each tomcat or separate the JENNIFER server from the JENNIFER agent.

Guest User

The business server is set in tomcat 6.0.26.
JENNIFER is set in tomcat 5.5.
And, the agent is set in tomcat 6.0.26.
When I try to set the agent, the “Servlet default is not available” error occurs and I can’t start the agent either.
This is a business server that can’t go down often. What is the reason for this problem?

Khalid Saeed

Assuming that the JENNIFER agent directory is /jennifer/agent,
1. In the agent directory, create the file called lwst.jdk.jar.
lwst40.sh jdk15 $JAVA_HOME/jre/lib/rt.jar
2. Set the options for tomcat6 (3 types)
-Djennifer.config=/jennifer/agent/w11.conf
-javaagent:/jennifer/agent/lwst.javaagent.jar
-Xbootclasspath/p:/jennifer/agent/lwst.boot.jar:/jennifer/agent/lwst.jdk.jar:/jennifer/agent/jennifer.boot.jar
3. Modify the agent configuration file(w11.conf).
using_adaptable_http_agent=true
http_agent_classpath=/jennifer/agent/jennifer.http.jar
4. After testing the libjennifer20.so file, place it in the directory below JRE where the *.so files exist.
And delete the Jennifer.jar file existing in the tomcat6/lib directory.